$re = '/^
(?!
(?:(?=.*0)(?=.*1)(?=.*2))
|
(?:(?=.*1)(?=.*2)(?=.*3))
|
(?:(?=.*2)(?=.*3)(?=.*4))
|
(?:(?=.*3)(?=.*4)(?=.*5))
|
(?:(?=.*4)(?=.*5)(?=.*6))
|
(?:(?=.*5)(?=.*6)(?=.*7))
|
(?:(?=.*6)(?=.*7)(?=.*8))
|
(?:(?=.*7)(?=.*9)(?=.*9))
)
.*
/mx';
$str = '124
124578
482715
123
312
1245789
7492158
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);