#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi).*(\d{3})(?:-?([a-z]))?\b"
Local $sString = "1-0101" & @CRLF & _
"101" & @CRLF & _
"101-A" & @CRLF & _
"101a" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)