$re = '/.*(\d{3})(?:-?([a-z]))?\b/mi';
$str = '1-0101
101
101-A
101a
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;