use strict;
my $str = '1-0101
101
101-A
101a
';
my $regex = qr/.*(\d{3})(?:-?([a-z]))?\b/mip;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";