package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi).*(\d{3})(?:-?([a-z]))?\b`)
var str = `1-0101
101
101-A
101a
`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}