re = /.*(\d{3})(?:-?([a-z]))?\b/mi
str = '1-0101
101
101-A
101a
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result