const regex = /.*(\d{3})(?:-?([a-z]))?\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(\\d{3})(?:-?([a-z]))?\\b', 'gmi')
const str = `1-0101
101
101-A
101a
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);