# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+)|\D+/$1\n/gm;t' <<< "123456
123-456
12-text
12-text-345
text-12-text-345"