const regex = /(\d+)|\D+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)|\\D+', 'gm')
const str = `123456
123-456
12-text
12-text-345
text-12-text-345`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);