using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)|\D+";
string substitution = @"$1\n";
string input = @"123456
123-456
12-text
12-text-345
text-12-text-345";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}