#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+)|\D+"
Local $sString = "123456 " & @CRLF & _
"123-456" & @CRLF & _
"12-text" & @CRLF & _
"12-text-345" & @CRLF & _
"text-12-text-345"
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)