$re = '/(\d+)|\D+/m';
$str = '123456
123-456
12-text
12-text-345
text-12-text-345';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;