const regex = /(^|[^\/\n])\/([^\/\n]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^\\\/\\n])\\\/([^\\\/\\n]|$)', 'gm')
const str = `NOOOOO//ABCDEFGHI/asdfasd//sdkksksks
/as12
as123/
asd123//
//
//a//
/`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);