import re
regex = re.compile(r"(^|[^\/\n])\/([^\/\n]|$)", flags=re.MULTILINE)
test_str = ("NOOOOO//ABCDEFGHI/asdfasd//sdkksksks\n"
"/as12\n"
"as123/\n"
"asd123//\n"
"//\n"
"//a//\n"
"/")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)