re = /(^|[^\/\n])\/([^\/\n]|$)/m
str = 'NOOOOO//ABCDEFGHI/asdfasd//sdkksksks
/as12
as123/
asd123//
//
//a//
/'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result