import Foundation
let pattern = #"(^|[^\/\n])\/([^\/\n]|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
NOOOOO//ABCDEFGHI/asdfasd//sdkksksks
/as12
as123/
asd123//
//
//a//
/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)