use strict;
my $str = 'NOOOOO//ABCDEFGHI/asdfasd//sdkksksks
/as12
as123/
asd123//
//
//a//
/';
my $regex = qr/(^|[^\/\n])\/([^\/\n]|$)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";