# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\[prev)( title="[^"]+")( cont="[^"]+" res="[^"]+")/$2$1/gm;t' <<< "[prev title=\"sample1\" cont=\"sample1a\" res=\"sample1b\" mw=\"1\"][prev title=\"sample2\" cont=\"sample2a\" res=\"sample2b\" mw=\"2\"][prev title=\"sample3\" cont=\"sample3a\" res=\"sample3b\" mw=\"3\"]."