$re = '/(?<=\[prev)( title="[^"]+")( cont="[^"]+" res="[^"]+")/m';
$str = '[prev title="sample1" cont="sample1a" res="sample1b" mw="1"][prev title="sample2" cont="sample2a" res="sample2b" mw="2"][prev title="sample3" cont="sample3a" res="sample3b" mw="3"].';
$subst = "$2$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;