const regex = /(?<=\[prev)( title="[^"]+")( cont="[^"]+" res="[^"]+")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\[prev)( title="[^"]+")( cont="[^"]+" res="[^"]+")', 'gm')
const str = `[prev title="sample1" cont="sample1a" res="sample1b" mw="1"][prev title="sample2" cont="sample2a" res="sample2b" mw="2"][prev title="sample3" cont="sample3a" res="sample3b" mw="3"].`;
const subst = `$2$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);