import Foundation
let pattern = #"(?<=\[prev)( title="[^"]+")( cont="[^"]+" res="[^"]+")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[prev title="sample1" cont="sample1a" res="sample1b" mw="1"][prev title="sample2" cont="sample2a" res="sample2b" mw="2"][prev title="sample3" cont="sample3a" res="sample3b" mw="3"]."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)