using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z]{4,8}[0-9]{0,4}$|^[a-z]{4,12}$";
string input = @"testtesttest
testtesttestr
test12345
testtest1234
testte123432
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}