// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z]{4,8}[0-9]{0,4}$|^[a-z]{4,12}$").unwrap();
let string = "testtesttest
testtesttestr
test12345
testtest1234
testte123432
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}