$re = '/^[a-z]{4,8}[0-9]{0,4}$|^[a-z]{4,12}$/m';
$str = 'testtesttest
testtesttestr
test12345
testtest1234
testte123432
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);