const regex = /^[a-z]{4,8}[0-9]{0,4}$|^[a-z]{4,12}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]{4,8}[0-9]{0,4}$|^[a-z]{4,12}$', 'gm')
const str = `testtesttest
testtesttestr
test12345
testtest1234
testte123432
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}