re = /^[a-z]{4,8}[0-9]{0,4}$|^[a-z]{4,12}$/m
str = 'testtesttest
testtesttestr
test12345
testtest1234
testte123432
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end