#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{2})([\.\/-]?)(\d{4})([\.\/-]?)(\d{3})([\.\/-])?(\d{1,7})([\.\/-]?)(\d{2})"
Local $sString = "25.0296.110.0003087.20 18" & @CRLF & _
"25-0296-110-0003087-20" & @CRLF & _
"25/0296/110/0003087/20" & @CRLF & _
"25.0296-110/0003087/20" & @CRLF & _
"250296110000308720" & @CRLF & _
"250296110308720" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")