re = /(\d{2})([\.\/-]?)(\d{4})([\.\/-]?)(\d{3})([\.\/-])?(\d{1,7})([\.\/-]?)(\d{2})/
str = '25.0296.110.0003087.20 18
25-0296-110-0003087-20
25/0296/110/0003087/20
25.0296-110/0003087/20
250296110000308720
250296110308720
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end