package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2})([\.\/-]?)(\d{4})([\.\/-]?)(\d{3})([\.\/-])?(\d{1,7})([\.\/-]?)(\d{2})`)
var str = `25.0296.110.0003087.20 18
25-0296-110-0003087-20
25/0296/110/0003087/20
25.0296-110/0003087/20
250296110000308720
250296110308720
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}