const regex = /(\d{2})([\.\/-]?)(\d{4})([\.\/-]?)(\d{3})([\.\/-])?(\d{1,7})([\.\/-]?)(\d{2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2})([\\.\\\/-]?)(\\d{4})([\\.\\\/-]?)(\\d{3})([\\.\\\/-])?(\\d{1,7})([\\.\\\/-]?)(\\d{2})', 'g')
const str = `25.0296.110.0003087.20 18
25-0296-110-0003087-20
25/0296/110/0003087/20
25.0296-110/0003087/20
250296110000308720
250296110308720
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}