import re
regex = re.compile(r"(\d{2})([\.\/-]?)(\d{4})([\.\/-]?)(\d{3})([\.\/-])?(\d{1,7})([\.\/-]?)(\d{2})")
test_str = ("25.0296.110.0003087.20 18\n"
"25-0296-110-0003087-20\n"
"25/0296/110/0003087/20\n"
"25.0296-110/0003087/20\n"
"250296110000308720\n"
"250296110308720\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")