# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{\s*\[(\w*)\]\s*(\w*)\s*\(([\w\s]*)\)\s*}/{[a]$1b$2(c)$3)}/g;t' <<< "{[]()}"