#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "{\s*\[(\w*)\]\s*(\w*)\s*\(([\w\s]*)\)\s*}"
Local $sString = "{[]()}"
Local $sSubst = "{[a]$1b$2(c)$3)}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)