$re = '/{\s*\[(\w*)\]\s*(\w*)\s*\(([\w\s]*)\)\s*}/';
$str = '{[]()}';
$subst = "{[a]$1b$2(c)$3)}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;