using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\s*\[(\w*)\]\s*(\w*)\s*\(([\w\s]*)\)\s*}";
string substitution = @"{[a]$1b$2(c)$3)}";
string input = @"{[]()}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}