re = /{\s*\[(\w*)\]\s*(\w*)\s*\(([\w\s]*)\)\s*}/
str = '{[]()}'
subst = '{[a]$1b$2(c)$3)}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result