// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{\s*\[(\w*)\]\s*(\w*)\s*\(([\w\s]*)\)\s*}").unwrap();
let string = "{[]()}";
let substitution = "{[a]$1b$2(c)$3)}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}