import Foundation
let pattern = #"{\s*\[(\w*)\]\s*(\w*)\s*\(([\w\s]*)\)\s*}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"{[]()}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{[a]$1b$2(c)$3)}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)