using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s.*?\sclass=""\s*view\s*""[^>]*>.*?<\/a>";
string input = @"<a title=""viwe"" class=""view"" href=""link"">blablabla</a><a title=""viwe"" class="" view "" href=""link"">blablabla</a><a title=""viwe"" class="" view "" href=""link"">blablabla</a>
<a title=""viwe"" class=""noview"" href=""link"">blablabla</a>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}