import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s.*?\\sclass=\"\\s*view\\s*\"[^>]*>.*?<\\/a>";
final String string = "<a title=\"viwe\" class=\"view\" href=\"link\">blablabla</a><a title=\"viwe\" class=\" view \" href=\"link\">blablabla</a><a title=\"viwe\" class=\" view \" href=\"link\">blablabla</a>\n"
+ "<a title=\"viwe\" class=\"noview\" href=\"link\">blablabla</a>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}