$re = '/<a\s.*?\sclass="\s*view\s*"[^>]*>.*?<\/a>/m';
$str = '<a title="viwe" class="view" href="link">blablabla</a><a title="viwe" class=" view " href="link">blablabla</a><a title="viwe" class=" view " href="link">blablabla</a>
<a title="viwe" class="noview" href="link">blablabla</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);