re = /<a\s.*?\sclass="\s*view\s*"[^>]*>.*?<\/a>/m
str = '<a title="viwe" class="view" href="link">blablabla</a><a title="viwe" class=" view " href="link">blablabla</a><a title="viwe" class=" view " href="link">blablabla</a>
<a title="viwe" class="noview" href="link">blablabla</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end