package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a\s.*?\sclass="\s*view\s*"[^>]*>.*?<\/a>`)
var str = `<a title="viwe" class="view" href="link">blablabla</a><a title="viwe" class=" view " href="link">blablabla</a><a title="viwe" class=" view " href="link">blablabla</a>
<a title="viwe" class="noview" href="link">blablabla</a>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}