# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!\B\w)(?:\(not working text|working text)(?!\B\w)/<mark>$&<\/mark>/g;t' <<< "working text and (not working text"