use strict;
my $str = 'working text and (not working text';
my $regex = qr/(?!\B\w)(?:\(not working text|working text)(?!\B\w)/p;
my $subst = '<mark>$&</mark>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";