$re = '/(?!\B\w)(?:\(not working text|working text)(?!\B\w)/';
$str = 'working text and (not working text';
$subst = "<mark>$&</mark>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;