re = /(?!\B\w)(?:\(not working text|working text)(?!\B\w)/
str = 'working text and (not working text'
subst = '<mark>$&</mark>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result