import Foundation
let pattern = #"(?!\B\w)(?:\(not working text|working text)(?!\B\w)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"working text and (not working text"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<mark>$&</mark>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)