#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?!\B\w)(?:\(not working text|working text)(?!\B\w)"
Local $sString = "working text and (not working text"
Local $sSubst = "<mark>$&</mark>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)