using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\B\w)(?:\(not working text|working text)(?!\B\w)";
string substitution = @"<mark>$&</mark>";
string input = @"working text and (not working text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}